Activation region - half of actors missing

Non-platform specific questions.

Activation region - half of actors missing

Postby lverona » Tue May 08, 2012 12:14 pm

Hey guys!
Probably a noob question here - I just learned from forums about activation regions. Tried dividing my game into several regions just to not have all the actors created at the same time. But the instant problem is that in one region everything seems to be ok, but in another half of the actors are not shown.

What can be the problem?

Also - is there any article or forum post on activation regions and how exactly do they work?
lverona
 
Posts: 180
Joined: Tue Apr 24, 2012 11:54 am
Score: 1 Give a positive score

Re: Activation region - half of actors missing

Postby skydereign » Tue May 08, 2012 3:38 pm

That shouldn't happen if the regions are placed correctly. Here is a forum post on it.
http://game-editor.com/forum/viewtopic.php?f=5&t=10933&p=75596&#p75596
And in gE's documentation there is a bit on it.
http://game-editor.com/docs/gettingstarted_maineditormenu.htm
User avatar
skydereign
 
Posts: 3463
Joined: Mon Jul 28, 2008 8:29 am
Score: 571 Give a positive score

Re: Activation region - half of actors missing

Postby lverona » Tue May 08, 2012 5:09 pm

I read it all. Don't understand what am I doing wrong.

I am submitting my game file. Can you please take a look at it?

Two problems with it.

1. The region in which you start - if you jump up a little bit higher - many of the actors are missing. They are displayed in the editor, but not in game mode.
2. If you jump up a little bit on the platforms, GE crashes with a segfault. It seems that it happens as soon as the view parts with the activation region right below it.

I am sure I am making a noob mistake here %)

edit: jump with Z. To avoid crash, you can use W to jump very high. For some reason this avoids the crash.
Attachments
Moon2.zip
(1.33 MiB) Downloaded 14 times
lverona
 
Posts: 180
Joined: Tue Apr 24, 2012 11:54 am
Score: 1 Give a positive score

Re: Activation region - half of actors missing

Postby skydereign » Tue May 08, 2012 5:44 pm

I can't cause either of the problems to happen. I am using Moon2.ged, since Moon.ged won't load.
User avatar
skydereign
 
Posts: 3463
Joined: Mon Jul 28, 2008 8:29 am
Score: 571 Give a positive score

Re: Activation region - half of actors missing

Postby lverona » Tue May 08, 2012 5:46 pm

I apologise - yes, you need to use Moon2, this is correct...
Weird. This happens on my machine and it also manifests itself in an executable although the executable does not crash - but it does not display half of the tiles if you jump up the platforms - where you see this thing on the wheel...
lverona
 
Posts: 180
Joined: Tue Apr 24, 2012 11:54 am
Score: 1 Give a positive score

Re: Activation region - half of actors missing

Postby lverona » Tue May 08, 2012 5:53 pm

In fact, what I found is that I can use the high jump - and I can see the ship on the wheel with all the tiles, but then when I jump up using platforms - half of the ship is gone - the tiles are gone. So if I go a little bit down, without exiting the region, the tiles get erased.
lverona
 
Posts: 180
Joined: Tue Apr 24, 2012 11:54 am
Score: 1 Give a positive score

Re: Activation region - half of actors missing

Postby skydereign » Tue May 08, 2012 5:59 pm

Okay, I can at least see a similar problem. I have to exit the region by skyrocketing to the top. As I fall the tiles are gone. I'll look into it.
User avatar
skydereign
 
Posts: 3463
Joined: Mon Jul 28, 2008 8:29 am
Score: 571 Give a positive score


Return to General

Who is online

Users browsing this forum: No registered users and 0 guests