Xcode 4.2 Help!!!

iPhone/iPod/iPad specific questions and discussion

Re: Xcode 4.2 Help!!!

Postby akr » Mon Mar 19, 2012 3:31 pm

How do your buildsettings look like?
Co-Developer of GE engine

If u are interrested in new features of apple or android ge engines check the engine support website game-editor.net regulary.
akr
 
Posts: 453
Joined: Thu Feb 25, 2010 7:56 pm
Location: Germany, Ulm
Score: 40 Give a positive score

Re: Xcode 4.2 Help!!!

Postby RippeR7420 » Mon Mar 19, 2012 4:51 pm

Here is the build for my Target;

http://i1006.photobucket.com/albums/af1 ... 4704AM.png

and this is the build for my Project;


http://i1006.photobucket.com/albums/af1 ... 4656AM.png

now, I've tried to change my target's build settings to "Armv7", But I got even bigger errors. as, It wouldn't
let archive my game at all.
User avatar
RippeR7420
 
Posts: 344
Joined: Mon Apr 27, 2009 4:16 pm
Location: Salt Lake City, Utah.
Score: 15 Give a positive score

Re: Xcode 4.2 Help!!!

Postby RippeR7420 » Tue Mar 20, 2012 1:48 am

I've just about tried everything I can think to fix this error. :(
Am I suppose to set the target device to a lower version than 5.0 maybe?
User avatar
RippeR7420
 
Posts: 344
Joined: Mon Apr 27, 2009 4:16 pm
Location: Salt Lake City, Utah.
Score: 15 Give a positive score

Re: Xcode 4.2 Help!!!

Postby akr » Tue Mar 20, 2012 6:21 am

Co-Developer of GE engine

If u are interrested in new features of apple or android ge engines check the engine support website game-editor.net regulary.
akr
 
Posts: 453
Joined: Thu Feb 25, 2010 7:56 pm
Location: Germany, Ulm
Score: 40 Give a positive score

Re: Xcode 4.2 Help!!!

Postby RippeR7420 » Tue Mar 20, 2012 5:55 pm

Thank you Akr. :)

what I had to end up doing, was lowering the target version to 3.2. But it worked.
My app is under review. :D
User avatar
RippeR7420
 
Posts: 344
Joined: Mon Apr 27, 2009 4:16 pm
Location: Salt Lake City, Utah.
Score: 15 Give a positive score

Re: Xcode 4.2 Help!!!

Postby peedalein » Thu Jun 28, 2012 10:01 am

Hello!

I got a problem with Xcode 5.1. The build and archive is fine but when I try to submit it to itunes I get the error message (see screenshot):

"application executable is missing a required architecture. At least one of the following architecture(s) must be present: armv6".

When I set architectures to armv6 armv7, the build fails.

I tried to use a new geapp project, set the target to 3.2 and checked the link provided by akr. It did not help. Please advise
Attachments
Screen Shot 2012-06-28 at 11.41.33 AM.png
peedalein
 
Posts: 54
Joined: Mon May 17, 2010 2:26 pm
Score: 1 Give a positive score

Re: Xcode 4.2 Help!!!

Postby REDNSX » Fri Jul 06, 2012 5:58 pm

What helped me was using the app loaded from Xcode 3. When I upload it with the uploaded from Xcode 4 it gives me the same error. Just use the old app loader and you will be fine.
User avatar
REDNSX
 
Posts: 235
Joined: Sun Feb 13, 2011 3:03 am
Score: 7 Give a positive score

Previous

Return to iOS

Who is online

Users browsing this forum: No registered users and 1 guest